Back to overview
Resolved

Sandbox Outbound Call Queue is down

Jul 23, 2026 at 12:48pm UTC
Affected services
Sandbox Outbound Call Queue

Resolved
Jul 23, 2026 at 12:48pm UTC

Sandbox Outbound Call Queue recovered.

Created
Jul 23, 2026 at 12:48pm UTC

Sandbox Outbound Call Queue is degraded.