Back to overview
Degraded
UI and Sandbox Outbound Call Queue are down
Feb 24, 2026 at 4:32pm UTC
Affected services
UI
Sandbox Outbound Call Queue
Resolved
Feb 24, 2026 at 7:11pm UTC
Sandbox Outbound Call Queue recovered.
Affected services
Updated
Feb 24, 2026 at 7:09pm UTC
Sandbox Outbound Call Queue is degraded.
Affected services
Updated
Feb 24, 2026 at 4:44pm UTC
UI recovered.
Affected services
Created
Feb 24, 2026 at 4:32pm UTC
UI is degraded.
Affected services